Autodesk.Revit.Exceptions Namespace

 
Classes
 ClassDescription
Public classAccessDeniedException 
Public classApplicationExceptionThe exception that is thrown when a non-fatal application error occurs.
Public classArgumentExceptionThe exception that is thrown when one of the arguments provided to a method is not valid.
Public classArgumentNullExceptionThe exception that is thrown when is passed to a method that does not accept it as a valid argument.
Public classArgumentOutOfRangeExceptionThe exception that is thrown when the value of an argument is outside the allowable range of values as defined by the invoked method.
Public classArgumentsInconsistentExceptionThe exception that is thrown when each individual argument is OK, but a joint constraint is violated.
Public classAutoJoinFailedExceptionThe exception that is thrown when an autojoin operation failed.
Public classBackgroundTaskCancelledExceptionThe exception thrown when Revit cancels a background operation. Third-party developers are not expected to catch and handle this exception. Instead, if allowed to propagate back to Revit code, it will be handled by Revit.
Public classCannotOpenBothCentralAndLocalExceptionThe exception thrown when both a central model and also a local file for the same central model are opened in the same session.
Public classCentralFileCommunicationExceptionThe exception thrown when there is a network communication error involving a file-based central model.
Public classCentralModelAccessDeniedExceptionThe exceptions thrown when a central model can be reached but access is denied due to a lack of access privileges.
Public classCentralModelAlreadyExistsExceptionException is thrown when the central model already exists at the specified location.
Public classCentralModelContentionExceptionThe exception thrown when a central model is busy (locked) and the operation is canceled.
Public classCentralModelExceptionThe base class for exceptions that are common to both file-based and server-based central models or specific to just file-based central models.
Public classCode exampleCentralModelVersionArchivedExceptionException is thrown when last central version merged into the local model has been archived in the central model. Reload Latest or Synchronized with Central needs to be conducted before the current failed operation is retried.
Public classCode exampleCheckoutElementsRequestTooLargeExceptionException is thrown when too many elements are requested for checkout
Public classCorruptModelExceptionThe exception that is thrown when the model is or seems corrupt.
Public classDefaultValueExceptionThe exception thrown when Revit cannot initialize a default value for a family parameter.
Public classDirectoryNotEmptyExceptionThe exception that is thrown when a method received a directory as an argument and requires that the directory be empty but the directory is not empty.
Public classDirectoryNotFoundExceptionThe exception that is thrown when the specified directory could not be found.
Public classDisabledDisciplineExceptionThe exception that is thrown when the function cannot execute because a discipline is disabled. The exception specifies which discipline(s) would let the operation succeed.
Public classExternalApplicationExceptionThe exception that is thrown when an issue in the Add-Ins resulted in an unexpected error.
Public classFamilyContextExceptionThe exception that is thrown when an operation is invalid in the current family document, because of the type of family.
Public classFileAccessExceptionThe exception that is thrown when the specified file could not be accessed, e.g. read-only, locked by the OS etc.
Public classFileArgumentAlreadyExistsExceptionThe exception that is thrown when the specified file exists.
Public classFileArgumentNotFoundExceptionThe exception that is thrown when a method received a filename as an argument and requires it to exist as a precondition.
Public classFileNotFoundExceptionThe exception that is thrown when the specified file could not be found.
Public classForbiddenForDynamicUpdateExceptionThe exception that is thrown when making or attempting to make changes that are forbidden during dynamic updates to the model.
Public classFunctionIdThe information of a function throwing an exception.
Public classInapplicableDataExceptionThe exception that is thrown when attempting to access a piece of data that is structurally not part of an object at the moment.
Public classInsufficientResourcesExceptionThe exception that is thrown when the OS runs out of resources, e.g. memory, disk space, or USER or GDI objects.
Public classInternalExceptionThe exception that is thrown when an issue in the Revit code resulted in an unexpected error.
Public classInvalidDataStreamExceptionThe exception that is thrown when the reading or saving operation failed due to parsing error.
Public classInvalidObjectExceptionThe exception that is thrown when referencing an object that is no longer valid.
Public classInvalidOperationExceptionThe exception that is thrown when a method call is invalid for the object's current state.
Public classInvalidPathArgumentExceptionThe exception that is thrown when a method received a pathname as an argument, but the pathname is illegal: too long, invalid characters, etc.
Public classIOExceptionThe exception that is thrown when an I/O error occurs.
Public classModificationForbiddenExceptionThe exception that is thrown by the undo transaction framework when a modification operation is not allowed.
Public classModificationOutsideTransactionExceptionThe exception that is thrown by the undo transaction framework when the modification operation to the model is outside of a transaction.
Public classNetworkCommunicationException 
Public classNotTransmittedModelExceptionThe exception thrown when OpenOptions were provided to deal with a transmitted model, but the model is not transmitted.
Public classObjectAccessExceptionThe exception that is thrown when an operation is denied, e.g. an attempt was made to set a read-only property.
Public classOperationCanceledExceptionThe exception that is thrown when an operation is unexpectedly cancelled.
Public classOptionalFunctionalityNotAvailableExceptionThe exception that is thrown when the optional functionality is not available in the installed Revit
Public classOutdatedDirectlyOpenedCentralExceptionThe exception thrown when a central model is opened directly and its copy in the session is outdated. If the operation is supported for local files, first resave as local, and try again.
Public classRegenerationFailedExceptionThe exception that is thrown when a regeneration operation failed.
Public classResourceNotFoundException 
Public classRevitServerCollaborationNotAvailableExceptionThe exception that is thrown when Collaboration fails because of an external resource (e.g., Amazon S3) failure.
Public classRevitServerCommunicationExceptionThe exception that is thrown when there is any network communication error happening.
Public classRevitServerExceptionThe exception that is base class for all exceptions originating from the Revit server.
Public classRevitServerInternalExceptionThe exception that is thrown when there is any server internal error happening.
Public classRevitServerModelAlreadyExistsExceptionThe exception that is thrown when there is a model with the same name already exist.
Public classRevitServerModelNameBreaksConventionExceptionThe exception that is thrown when the model is breaking the project naming convention.
Public classRevitServerUnauthenticatedUserExceptionThe exception that is thrown when an unauthenticated user attempts to initiate a call to RevitServer.
Public classRevitServerUnauthorizedExceptionThe exception that is thrown when a call to the server is unauthorized.
Public classSchemaExceptionThe exception thrown when Revit cannot interpret a data structure described by a schema.
Public classServerInternalException 
Public classTransientElementCreationExceptionThe exception that is thrown when TransientElementCreationScope is used incorrectly.
Public classTransmittedModelExceptionThe exception thrown when model was transmitted (sent by eTransmit) and insufficient OpenOptions were provided to handle its transmitted flag.
Public classUnauthenticatedException 
Public classWrongUserExceptionThe exception thrown when a local model is manipulated under a different username than it was created with.