SelectionPickPoint Method

Prompts the user to pick a point on the active work plane.

Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ PickPoint()

Return Value

XYZ

The point picked by user.

Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.

Exceptions
ExceptionCondition
InvalidOperationExceptionThrown when no work plane set in current view.
OperationCanceledExceptionThrown when the Revit user cancelled this operation. Thrown when the Revit user tried to close the active document or Revit application when responding to this mode.
ForbiddenForDynamicUpdateExceptionThrown if this method is called during dynamic update.
Remarks
Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.

Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.

See Also