Indicates whether the mesh is closed.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsClosed { get; }
Public ReadOnly Property IsClosed As Boolean
Get
public:
property bool IsClosed {
bool get ();
}
member IsClosed : bool with get
Property Value
Boolean
Remarks
Every time this property is accessed, it is computed from scratch,
so accessing it multiple times will come at a performance cost.
A mesh is closed when each of its edges has two (or more) faces.
If an edge has more than two faces (meaning that it's a non-manifold edge),
the mesh still may be closed.
See Also