DirectShapeReferenceOptionsName Property |
The name associated with the reference object.
The name does not need to be unique.
The name must not be empty and must contain valid characters.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string Name { get; set; }
Public Property Name As String
Get
Set
public:
property String^ Name {
String^ get ();
void set (String^ value);
}
member Name : string with get, set
Property Value
String
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: value cannot be used as a name for the direct shape reference.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
See Also