AnalyticalLoopType Enumeration |
Specifies kind of analytical model loop.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum AnalyticalLoopType
Public Enumeration AnalyticalLoopType
public enum class AnalyticalLoopType
MembersMember name | Value | Description |
---|
All | 0 |
All analytical loops of analytical model surface elements (floor, slab, wall).
|
External | 1 |
Loops outside all other loops.
In case of multiple nested loops, this will return the most external loop.
|
Internal | 2 |
An internal loop is a loop that is inside another loop.
In the case of multiple nested loops, this will return all loops except the most external loop.
|
Filled | 3 |
Loops that are filled inside.
In the case of multiple nested loops, this will return the most external and every second loop going from external to internal.
In the view, returned loops are presented as external outline of solids.
|
Void | 4 |
Loops that are empty inside.
In the case of multiple nested loops, this will return a series of loops starting from second most external and every second heading into the most internal.
In the view returned loops are presented as external outline of openings.
|
See Also