ArcCreate(XYZ, XYZ, XYZ) Method |
Creates a new geometric arc object based on three points.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Arc Create(
XYZ end0,
XYZ end1,
XYZ pointOnArc
)
Public Shared Function Create (
end0 As XYZ,
end1 As XYZ,
pointOnArc As XYZ
) As Arc
public:
static Arc^ Create(
XYZ^ end0,
XYZ^ end1,
XYZ^ pointOnArc
)
static member Create :
end0 : XYZ *
end1 : XYZ *
pointOnArc : XYZ -> Arc
Parameters
- end0 XYZ
-
The start point of the arc.
- end1 XYZ
-
The end point of the arc.
- pointOnArc XYZ
-
A point on the arc.
Return Value
Arc
The new arc.
ExceptionsException | Condition |
---|
ArgumentNullException |
A non-optional argument was NULL
|
ArgumentsInconsistentException |
The vectors end0 and end1 are coincident.
-or-
The vectors end0 and pointOnArc are coincident.
-or-
The vectors end1 and pointOnArc are coincident.
-or-
Cannot create an arc.
-or-
Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance).
|
Example
XYZ end0 = new XYZ(1, 0, 0);
XYZ end1 = new XYZ(10, 10, 10);
XYZ pointOnCurve = new XYZ(10, 0, 0);
Arc arc = Arc.Create(end0, end1, pointOnCurve);
Dim end0 As New XYZ(1, 0, 0)
Dim end1 As New XYZ(10, 10, 10)
Dim pointOnCurve As New XYZ(10, 0, 0)
Dim arc__1 As Arc = Arc.Create(end0, end1, pointOnCurve)
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also