ModelCurveTrussCurveType Property |
The truss curve type of this model curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic TrussCurveType TrussCurveType { get; set; }
Public Property TrussCurveType As TrussCurveType
Get
Set
public:
property TrussCurveType TrussCurveType {
TrussCurveType get ();
void set (TrussCurveType value);
}
member TrussCurveType : TrussCurveType with get, set
Property Value
TrussCurveType
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException | Thrown when the assigned value for TrussCurveType is invalid. |
InvalidOperationException | Thrown when attempting to set this property to a curve not in a truss family. |
InvalidOperationException | Thrown when attempting to change truss curves to NonTrussCurve, or when
the truss curve type may not be applied to curves of this shape (webs must be linear, and chords must be linear or arc). |
RemarksThis property is applicable only to curves in Truss families.
See Also