ImportInstanceCreate(Document, View, String, DWGImportOptions, LinkLoadResult) Method

Creates a new instance of DWG or DXF link type from a file path and loads the linked file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ImportInstance Create(
	Document document,
	View DBView,
	string path,
	DWGImportOptions options,
	out LinkLoadResult linkLoadResult
)

Parameters

document  Document
The document in which to create the DWG or DXF link.
DBView  View
The view into which the DWG or DXF link will be created.
path  String
The full path of the DWG or DXF file to link. The path must exist and must be a valid DWG or DXF file.
options  DWGImportOptions
Various import options applicable to the DWG format. If , all options will be set to their respective default values.
linkLoadResult  LinkLoadResult
An object containing the results of creating and loading the DWG or DXF link. It contains the ElementId of the new created DWG or DXF link type.

Return Value

ImportInstance
The new instance of DWG or DXF link type.
Exceptions
ExceptionCondition
ArgumentException document is not a project document. -or- document is in an edit mode. -or- Import is temporarily disabled. -or- The view is not printable. -or- NullOrEmpty -or- Not a valid file for DWG import (.dwg and .dxf files are valid). -or- ThisViewOnly cannot be true when importing a DWG|DGN drawing into a 3D view. -or- One or more strings describing layer selection is invalid or empty. -or- The line weights are not valid; either it contains an invalid number of line weights, or a line weight outside the valid range. -or- The scale is not valid as a CustomScale for use during import.
ArgumentNullException A non-optional argument was null
FileArgumentNotFoundException The given path does not exist.
InvalidOperationException Place by shared, and the host model and the link do not share the same coordinate system. Or place by shared, and the shared coordinates of the host model do not match the GIS coordinate system of the link.
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
OptionalFunctionalityNotAvailableException The DWG Import/Link module is not available in the installed Revit.
Remarks

This function creates a new DWG or DXF link type as well as a new instance of this link type. The new instance of DWG or DXF link type is returned by this function and the element id of the new DWG or DXF link type is contained in the LinkLoadResult.

If the given full path of the DWG or DXF file to link is already used by an existing DWG or DXF link type, a new instance of this existing DWG or DXF link type will be created and returned. The element id of the existing DWG or DXF link type is contained in the LinkLoadResult.

This function regenerates the input document.

See Also