SunAndShadowSettingsEndDateAndTime Property |
Identifies the end date and time.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic DateTime EndDateAndTime { get; set; }
Public Property EndDateAndTime As DateTime
Get
Set
public:
property DateTime EndDateAndTime {
DateTime get ();
void set (DateTime value);
}
member EndDateAndTime : DateTime with get, set
Property Value
DateTime
The date and time. The output value will be in Coordinated Universal Time (UTC), but input may be
in local time as well.
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: Revit does not accept input DateTime objects if they are of kind DateTypeKind.Unspecified.
|
Remarks
This property represents the end time for a single-day or multi-day study.
The end date and time can be set for any study type, but is not always used.
Note that Revit may ignore this value if the SunriseToSunset flag is set.
See Also