RebarConstraintGetTargetHostFaceReference Method |
Returns a reference to the host Element face to which the RebarConstraint is attached.
The RebarConstraintType of the RebarConstraint must be 'FixedDistanceToHostFace' or 'ToCover'.
Will throw exception if it's a multi target constraint.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Reference GetTargetHostFaceReference()
Public Function GetTargetHostFaceReference As Reference
public:
Reference^ GetTargetHostFaceReference()
member GetTargetHostFaceReference : unit -> Reference
Return Value
Reference
Requested reference.
ExceptionsException | Condition |
---|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover'.
-or-
Multi target constraint. Consider using the indexed version of the method.
|
See Also