AnalyticalSupportType Enumeration |
Indicates what kind of support another Element provides -- Point, Surface, or Curve.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum AnalyticalSupportType
Public Enumeration AnalyticalSupportType
public enum class AnalyticalSupportType
type AnalyticalSupportType
MembersMember name | Value | Description |
---|
UnknownSupport | 0 |
Support has not been determined.
|
PointSupport | 1 |
Support at just one point.
|
CurveSupport | 2 |
Support along a curve.
|
SurfaceSupport | 3 |
Support along a surface.
|
See Also