BuiltInFailuresStructuralConnectionFailures Class

Failures about StructuralConnectionHandler.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresStructuralConnectionFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class StructuralConnectionFailures

The BuiltInFailuresStructuralConnectionFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberStructuralConnectionCannotGenerate Could not create Structural Connection Handler
Public propertyStatic memberStructuralConnectionCannotReplaceRefs Structural Connection cannot replace elements
Public propertyStatic memberStructuralConnectionForbiddenElementInGroup Fabrication element can not be a group member.
Public propertyStatic memberStructuralConnectionNoSingleRef Summary: Structural Connection Handler lost connected element.
Public propertyStatic memberStructuralConnectionNotEnoughRefs Structural Connection Handler cannot connect fewer than two elements.
Public propertyStatic memberStructuralConnectionSetOfRefsChanged The set of input elements was changed and the connection has been adjusted.
Public propertyStatic memberStructuralConnectionTooFarNotEnoughRefs Structural Connection Handler cannot connect too far elements
Public propertyStatic memberStructuralConnectionTooFarRefs Structural Connection Handler cannot connect too far elements
Public propertyStatic memberStructuralConnectionTypeChangedToGeneric Structural Connection had an inappropriate type, which has been changed to 'Generic Connection'.
Public propertyStatic memberStructuralConnectionTypeInfoNotAvailable There is no add-on installed which supports Structural Connection type.
Public propertyStatic memberStructuralConnectionWrongType Structural Connection has an inappropriate type assigned.
Public propertyStatic memberStructuralSectionHasIncompleteDefinition Structural Section has incomplete definition
Top
See Also