HostObjectUtilsGetTopFaces Method |
Returns the top faces for this host object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<Reference> GetTopFaces(
HostObject hostObject
)
Public Shared Function GetTopFaces (
hostObject As HostObject
) As IList(Of Reference)
public:
static IList<Reference^>^ GetTopFaces(
HostObject^ hostObject
)
static member GetTopFaces :
hostObject : HostObject -> IList<Reference>
Parameters
- hostObject HostObject
-
The host object.
Return Value
IListReference
An array of references to the faces which are at the top of this element.
Exceptions
Remarks
This utility supports host objects whose top faces represent one of the boundaries
of CompoundStructure (such as roofs, floors or ceilings).
See Also