FamilyManagerRenameCurrentType Method

Rename the current family type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void RenameCurrentType(
	string typeName
)

Parameters

typeName  String
The new name of the current family type.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the input argument-"typeName"-is .
ArgumentException Thrown when the input argument-"typeName"-is already in use.
InvalidOperationException Thrown when the family type rename failed.
See Also