IExtensionExtended Property |
Retrieves or set the extension status at the end
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxbool this[
int index
] { get; set; }
Property Extended (
index As Integer
) As Boolean
Get
Set
property bool Extended[int index] {
bool get (int index);
void set (int index, bool value);
}
abstract Extended : bool with get, set
Parameters
- index Int32
-
Property Value
Boolean
RemarksProperty index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown.
For beams, if the beam extension status is changed, other status such as
the symbolic extension status, miter status, miter locked status, and
other beams extension status will be changed automatically at the same time.
This change can protect that a join can have up to two extended beams, if
there are two extended beams at the join, they shall be mitered.
See Also