IndependentTagSetLeaderElbow Method |
Set the position of the elbow of the tag's leader that points to specified reference.
If this tag is a multileader tag and the elbows are merged, the input position will be set to all leaders.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetLeaderElbow(
Reference referenceTagged,
XYZ elbowPosition
)
Public Sub SetLeaderElbow (
referenceTagged As Reference,
elbowPosition As XYZ
)
public:
void SetLeaderElbow(
Reference^ referenceTagged,
XYZ^ elbowPosition
)
member SetLeaderElbow :
referenceTagged : Reference *
elbowPosition : XYZ -> unit
Parameters
- referenceTagged Reference
-
The reference which is tagged.
- elbowPosition XYZ
-
The position of the elbow.
ExceptionsException | Condition |
---|
ArgumentException |
The specified reference is not currently tagged.
-or-
The leader for the tagged reference isn't visible.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The IndependentTag object does not have a tag behavior.
-or-
For this tag leaders are not allowed.
|
Remarks
Straight leaders do not have elbow points.
See Also