IMemberForcesServerMemberForcesUpdate Method |
The server's method that will be called when Revit User clicks Member Forces button in the MPP.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxbool MemberForcesUpdate(
MemberForcesServiceData data
)
Function MemberForcesUpdate (
data As MemberForcesServiceData
) As Boolean
bool MemberForcesUpdate(
MemberForcesServiceData^ data
)
abstract MemberForcesUpdate :
data : MemberForcesServiceData -> bool
Parameters
- data MemberForcesServiceData
-
The Moment Forces data.
Return Value
Boolean
Indicates whether themember forces parameter server is executed successfully.
Remarks
The server provides UI way for Revit user to view and modify the detail data corresponding with the parameter value.
The server may also modify the section type parameter value itself during the execution.
The method should always return 'true' if the server is successfully executed, no matter whether the server changes anything.
Return 'false' or if the server throws, indicates a failed case, all changes made by the server will be discarded.
See Also