FailureDefinitionGetDescriptionText Method |
Retrieves the description text of the failure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string GetDescriptionText()
Public Function GetDescriptionText As String
public:
String^ GetDescriptionText()
member GetDescriptionText : unit -> string
Return Value
String
The description text.
Remarks
Retrieved description text for built-in Revit failures is localized.
The result may vary from the description text retrieved from the corresponding FailureMessage.
A failure definition contains a description string, that may have format specifiers like %s, and "sample" strings,
that will be used to resolve them. A FailureMessage will contain "specific" strings.
So, in the failure definition description "Cannot keep %s joined" will be converted into "Cannot keep Element joined" while
the description in actual FailureMessage will read "Cannot keep Walls joined" or "Cannot keep Beams joined"
See Also