DirectShapeLibraryContains Method

A quick check whether a definition already exists in the library. Checks for stored geometry objects only.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Contains(
	string id
)

Parameters

id  String
Definition id

Return Value

Boolean
True if a geometry definition exists, false otherwise.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also