RebarFreeFormAccessorCycleCounter Property

Identifies the cycle counter. It can be zero or a pozitive number.

Its value is changed when the free form Rebar element is selected and the user press Space key -or- through the setter of this property -or- by the server if it considers that the counter reaches the maximum value and reset it (set it to 0). This property can be accessed just for Rebars that are controlled by a server.


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int CycleCounter { get; set; }

Property Value

Int32
Exceptions
ExceptionCondition
ArgumentOutOfRangeException When setting this property: The given value for cycleCounter is negative.
InvalidOperationException This RebarFreeFormAccessor doesn't contain a valid rebar reference. -or- This RebarFreeFormAccessor Rebar doesn't contain a valid server GUID.
See Also