FilteredWorksetCollectorFirstWorksetId Method |
Returns the id of the first workset to pass the filter(s).
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic WorksetId FirstWorksetId()
Public Function FirstWorksetId As WorksetId
public:
WorksetId^ FirstWorksetId()
member FirstWorksetId : unit -> WorksetId
Return Value
WorksetId
The first workset id.
ExceptionsException | Condition |
---|
InvalidOperationException |
The collector does not have a filter applied. Extraction or iteration of worksets is not permitted without a filter.
|
Remarks
This will reset the collector to the beginning and find the first workset that passes the applied filter(s).
If you have an active iterator to this same collector it will be stopped by this call.
See Also