BuildingOperatingYearScheduleCreate Method

Creates a valid BuildingOperatingYearSchedule with the given name, where every day has the schedule daySchedule.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static BuildingOperatingYearSchedule Create(
	Document document,
	BuildingOperatingDaySchedule daySchedule,
	string name
)

Parameters

document  Document
The document to create this BuildingOperatingYearSchedule for.
daySchedule  BuildingOperatingDaySchedule
A schedule to assign to every day.
name  String
The intended schedule name, may be modified to disambiguate with existing elements.

Return Value

BuildingOperatingYearSchedule
The newly created BuildingOperatingYearSchedule.
Exceptions
ExceptionCondition
ArgumentException daySchedule must be in the same document. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- name must be trimmed. -or- name is an empty string or contains only whitespace.
ArgumentNullException A non-optional argument was null
See Also