FamilySizeTableErrorType Enumeration |
The set of errors that can be returned when importing a FamilySizeTable from a CSV file.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum FamilySizeTableErrorType
Public Enumeration FamilySizeTableErrorType
public enum class FamilySizeTableErrorType
type FamilySizeTableErrorType
MembersMember name | Value | Description |
---|
FileNotFound | 0 |
The FamilySize Table CSV file was not found.
|
CannotOpenFile | 1 |
Failed to open the FamilySizeTable CSV file.
|
CannotReadFile | 2 |
Failed to read the FamilySizeTable CSV file.
|
InvalidHeaderSeparator | 3 |
The CSV file header separator is not invalid. Valid header separators are comma(,), semicolon(;), colon(:), and pipe (|).
|
CannotParseColumnHeader | 4 |
Failed to parse the column header of the FamilySizeTable CSV file.
|
IncorrectNumberOfColumns | 5 |
The number of columns in the header row of the FamilySizeTable CSV file is different than the number of columns of data.
|
Undefined | -1 |
Undefined error.
|
See Also