ReinforcementSettingsRebarShapeDefinesHooks Property |
Hooks are defined by Rebar Shape of Rebar element. Can be changed if document contains no rebars, area reinforcements and path reinforcements.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool RebarShapeDefinesHooks { get; set; }
Public Property RebarShapeDefinesHooks As Boolean
Get
Set
public:
property bool RebarShapeDefinesHooks {
bool get ();
void set (bool value);
}
member RebarShapeDefinesHooks : bool with get, set
Property Value
Boolean
ExceptionsException | Condition |
---|
InvalidOperationException |
When setting this property: Cannot change the RebarShapeDefinesHooks property in these settings because the document contains one or more Rebar elements.
-or-
When setting this property: Cannot change the RebarShapeDefinesHooks property in these settings because the document contains one or more AreaReinforcement or PathReinforcement
elements.
-or-
When setting this property: Cannot change the RebarShapeDefinesHooks property in these settings because the document contains one or more RebarContainer elements.
the document contains one or more RebarContainer elements.
|
See Also