StructuralFramingUtilsAllowJoinAtEnd Method |
Sets the indicated end of the framing element to be allowed to join to others.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static void AllowJoinAtEnd(
FamilyInstance familyInstance,
int end
)
Public Shared Sub AllowJoinAtEnd (
familyInstance As FamilyInstance,
end As Integer
)
public:
static void AllowJoinAtEnd(
FamilyInstance^ familyInstance,
int end
)
static member AllowJoinAtEnd :
familyInstance : FamilyInstance *
end : int -> unit
Parameters
- familyInstance FamilyInstance
-
The FamilyInstance, which must be of a structural framing category.
- end Int32
-
The index of the end (0 for the start, 1 for the end).
Exceptions
Remarks
If that end is near other elements it will become joined as a result.
By default all framing elements are allowed to join at ends, so this function is only needed if this element end is already disallowed to join.
See Also