StructuralSectionShape Enumeration

Shapes for structural sections.

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum StructuralSectionShape
Members
Member nameValueDescription
NotDefined0 Structural section was not defined for this element
RectangleParameterized2 Defines parameters for parameterized rectangle structural sections.
PipeStandard5 Defines parameters for pipes also known as RoundHSS or HollowStructuralSection (HSS).
IParallelFlange6 Defines parameters for I-shape Parallel Flange structural sections.
ISlopedFlange7 Defines parameters for I-shape Sloped Flange structural sections.
IWideFlange8 Defines parameters for I-shape Wide Flange structural sections.
CParallelFlange9 Defines parameters for C-channel Parallel Flange structural sections.
Invalid-1 This element do not support structural section.
CSlopedFlange10 Defines parameters for C-channel Sloped Flange structural sections.
LAngle11 Defines parameters for L-angle structural sections.
RectangularBar12 Defines parameters for Rectangular Bar structural sections.
RoundBar13 Defines parameters for Round Bar structural sections.
RectangleHSS14 Defines parameters for Rectangular HSS structural sections.
RoundHSS15 Defines parameters for Round HSS structural sections.
IWelded16 Defines parameters for I-shape Welded structural sections.
ISplitParallelFlange17 Defines parameters for I-split Parallel Flange structural sections.
ISplitSlopedFlange18 Defines parameters for I-split Sloped Flange structural sections.
StructuralTees19 Defines parameters for Structural Tees structural sections.
CProfile20 Defines parameters for structural C Profile sections.
CProfileWithLips21 Defines parameters for structural C Profile sections with lips .
CProfileWithFold22 Defines parameters for structural C Profile sections with fold.
LProfile23 Defines parameters for structural L Profile structural sections.
LProfileWithLips24 Defines parameters for structural L Profile sections with lips.
ZProfile25 Defines parameters for structural Z Profile structural sections.
ZProfileWithLips26 Defines parameters for structural L profile sections with lips.
SigmaProfile27 Defines parameters for Sigma Profile structural sections.
SigmaProfileWithLips28 Defines parameters for structural Sigma sections profile with lips.
SigmaProfileWithFold29 Defines parameters for structural Sigma sections profile with fold.
UserDefined30 Defines parameters for user defines structural sections.
ConcreteRectangle31 Defines parameters for Concrete Rectangle structural sections.
ConcreteRectangleCut32 Defines parameters for Concrete Rectangle Cut structural sections.
ConcreteT33 Defines parameters for Concrete T structural sections.
ConcreteCross34 Defines parameters for Concrete Cross structural sections.
ConcreteRound35 Defines parameters for ConcreteRound structural sections.
Remarks
Allow safely differentiate between classes inherited from Autodesk::Revit::DB::Structure::StructuralSections::StructuralSection class.
See Also