BuildingPadTypeCreateDefault Method

Creates a BuildingPadType element and adds it to the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static BuildingPadType CreateDefault(
	Document document
)

Parameters

document  Document
The document to be modified.

Return Value

BuildingPadType
The new BuildingPadType element.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
The default BuildiPadType adopts the value of 1.0 for the paremeter of thickness. If there is no BuildingPadType existing, will create a new one; otherwise, an exception will be thrown.
See Also