PartEdgeConditionOrientation Enumeration |
Relative orientation of the right/lower and left/upper edge condition profiles.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum PartEdgeConditionOrientation
Public Enumeration PartEdgeConditionOrientation
public enum class PartEdgeConditionOrientation
type PartEdgeConditionOrientation
MembersMember name | Value | Description |
---|
Complement | 0 |
Before division gap is applied the left/upper and right/lower profiles coincide
and neighboring panels complement each other precisely.
|
Mirrored | 1 |
Right/lower profile is obtained by mirroring the left/upper profile with respect to the
division line. The division gap is not applied.
|
MirroredAndRotated | 2 |
Right/lower profile is obtained first by mirroring the left/upper profile with respect to the
division line and then by mirroring the result with respect to the center line of the
divided thickness. The division gap is not applied.
|
Remarks
A family-based profile defines the shape of the left/upper profile and this
value defines how a matching right/lower profile is obtained.
See Also