ViewNodeLevelOfDetail Property

The level of detail the view is going to be rendered at.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int LevelOfDetail { get; set; }

Property Value

Int32
Exceptions
ExceptionCondition
ArgumentException When setting this property: The level of detail is not in valid range. It must be a number between -1 and 15, all inclusive.
Remarks

The value is an integer number in range of [0,15] (inclusive), or a value {-1}. If the value is positive, Revit will use the suggested level of detail when tessellating faces; otherwise it will use its default algorithm, which is based on output resolution.

If an explicit level of detail is requested (i.e. a positive value), using a value close to the middle of the valid range yields a very reasonable tessellation. Revit uses level 8 as its 'normal' LoD.

See Also