SystemsAnalysisOptionsOutputFolder Property |
The path of the output folder for systems analysis.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string OutputFolder { get; set; }
Public Property OutputFolder As String
Get
Set
public:
property String^ OutputFolder {
String^ get ();
void set (String^ value);
}
member OutputFolder : string with get, set
Property Value
String
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The analysis requires a valid output folder.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
When requesting a new system analysis, it is okay to have an empty output folder in the SystemsAnalysisOption. In that case,
the ViewSystemsAnalysisReport would supply the output folder, typically at the system TEMP folder.
See Also