FluidTypeCreate(Document, String, FluidType) Method |
Creates a new fluid type and adds it to the document.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static FluidType Create(
Document document,
string fluidTypeName,
FluidType basedOnFluidType
)
Public Shared Function Create (
document As Document,
fluidTypeName As String,
basedOnFluidType As FluidType
) As FluidType
public:
static FluidType^ Create(
Document^ document,
String^ fluidTypeName,
FluidType^ basedOnFluidType
)
static member Create :
document : Document *
fluidTypeName : string *
basedOnFluidType : FluidType -> FluidType
Parameters
- document Document
-
The document.
- fluidTypeName String
-
The name of new created fluid type.
- basedOnFluidType FluidType
-
The existing fluid type which is based on.
Return Value
FluidType
The newly created fluid type.
Exceptions
Remarks
The new fluid type will be a duplicate of the input type.
See Also