StructuralWallUsageFilter(StructuralWallUsage, Boolean) Constructor |
Constructs a new instance of a filter to match walls that have the given structural wall usage,
with the option to match all walls which are not of the given structural wall usage.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic StructuralWallUsageFilter(
StructuralWallUsage structuralWallUsage,
bool inverted
)
Public Sub New (
structuralWallUsage As StructuralWallUsage,
inverted As Boolean
)
public:
StructuralWallUsageFilter(
StructuralWallUsage structuralWallUsage,
bool inverted
)
new :
structuralWallUsage : StructuralWallUsage *
inverted : bool -> StructuralWallUsageFilter
Parameters
- structuralWallUsage StructuralWallUsage
-
The structural usage to match.
- inverted Boolean
-
True if the filter should match all walls which are not of the given structural wall usage.
Exceptions
See Also