TransmittedModelOptions Enumeration |
Enum giving desired behavior when opening or saving a transmitted
workshared model.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum TransmittedModelOptions
Public Enumeration TransmittedModelOptions
public enum class TransmittedModelOptions
type TransmittedModelOptions
MembersMember name | Value | Description |
---|
SaveAsNewCentral | 0 |
The model should be saved as a new central. (On open, it will be
saved as a new central in its current location. On save, it will be
saved as central but the user can choose a location.)
|
KeepAsTransmitted | 1 |
The model will remain marked as transmitted; users will not be able to
create locals until it is saved as a new central.
|
CancelOperation | 2 |
Cancel the save or load operation.
|
See Also