ConduitSizeIterator Class

An iterator to a set of conduit sizes from ConduitSizes.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.ElectricalConduitSizeIterator

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ConduitSizeIterator : IEnumerator<ConduitSize>

The ConduitSizeIterator type exposes the following members.

Properties
 NameDescription
Public propertyCurrentGets the item at the current position of the iterator.
Protected propertyCurrentObject 
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ConduitSizeIterator
Public methodGetCurrent Returns the current ConduitSize.
Public methodHasCurrent Identifies if the iterator has a current item.
Public methodIsDone Identifies if the iteration has completed.
Public methodMoveNext Increments the iterator to the next item.
Public methodReset Resets the iterator to the initial state.
Top
See Also