IndependentTagGetLeaderEnd Method |
Returns the end position of the tag's leader that points to specified reference.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic XYZ GetLeaderEnd(
Reference referenceTagged
)
Public Function GetLeaderEnd (
referenceTagged As Reference
) As XYZ
public:
XYZ^ GetLeaderEnd(
Reference^ referenceTagged
)
member GetLeaderEnd :
referenceTagged : Reference -> XYZ
Parameters
- referenceTagged Reference
-
The reference which is tagged.
Return Value
XYZ
Point representing the end position of tag's leader
ExceptionsException | Condition |
---|
ArgumentException |
There is no leader end because the tag does not use a free end leader or the leader is not visible.
-or-
The specified reference is not currently tagged.
|
ArgumentNullException |
A non-optional argument was null
|
InvalidOperationException |
The IndependentTag object does not have a tag behavior.
|
Remarks
Tags with attached leaders or no leaders do not support leader ends.
LeaderEndCondition for the tag's leader condition.
See Also