The triple product of this vector and the two specified vectors.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic double TripleProduct(
XYZ middle,
XYZ right
)
Public Function TripleProduct (
middle As XYZ,
right As XYZ
) As Double
public:
double TripleProduct(
XYZ^ middle,
XYZ^ right
)
member TripleProduct :
middle : XYZ *
right : XYZ -> float
Parameters
- middle XYZ
- The second vector.
- right XYZ
- The third vector.
Return Value
DoubleThe real number equal to the triple product.
Exceptions
Remarks
The scalar triple product is defined as the dot product of one of the vectors
with the cross product of the other two. Geometrically, this product is the (signed)
volume of the parallelepiped formed by the three vectors given.
See Also