PanelScheduleTemplateIsValidPanelConfiguration Method

Checks if given panel configuration is valid for given panel schedule type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsValidPanelConfiguration(
	PanelScheduleType scheduleType,
	PanelConfiguration configuration
)

Parameters

scheduleType  PanelScheduleType
The panel schedule type.
configuration  PanelConfiguration
The given configuration to check.

Return Value

Boolean
True if panel schedule template can have a valid configuration assigned, false otherwise.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
If the panel schedule type is branch panel, the valid panel configurations are: PanelConfiguration::Enum::OneColumn PanelConfiguration::Enum::TwoColumnsCircuitsAcross PanelConfiguration::Enum::TwoColumnsCircuitsDown If the panel schedule type is switchboard or data panel, the valid panel configuration is: PanelConfiguration::Enum::OneColumn
See Also