Creates a new instance of level based on an input elevation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Level Create(
Document document,
double elevation
)
Public Shared Function Create (
document As Document,
elevation As Double
) As Level
public:
static Level^ Create(
Document^ document,
double elevation
)
static member Create :
document : Document *
elevation : float -> Level
Parameters
- document Document
-
The document in which the new instance is created
- elevation Double
-
The elevation of the level to be created.
Return Value
Level
The newly created level instance.
Exceptions
ExampleLevel CreateLevel(Autodesk.Revit.DB.Document document)
{
double elevation = 20.0;
Level level = Level.Create(document, elevation);
if (null == level)
{
throw new Exception("Create a new level failed.");
}
level.Name = "New level";
return level;
}
Private Function CreateLevel(document As Autodesk.Revit.DB.Document) As Level
Dim elevation As Double = 20.0
Dim level As Level = level.Create(document, elevation)
If level Is Nothing Then
Throw New Exception("Create a new level failed.")
End If
level.Name = "New level"
Return level
End Function
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also