The Crop Box applied to the view, or an outline encompassing the crop region applied to the view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BoundingBoxXYZ CropBox { get; set; }
Public Property CropBox As BoundingBoxXYZ
Get
Set
public:
property BoundingBoxXYZ^ CropBox {
BoundingBoxXYZ^ get ();
void set (BoundingBoxXYZ^ value);
}
member CropBox : BoundingBoxXYZ with get, set
Property Value
BoundingBoxXYZ if the view is a template, or does not support cropping. If the view has a non-rectangular crop region, defined by
a sketch, the crop box will be the smallest box that contains the sketch. Setting the crop box for a view with a non-rectangular crop region will
have no effect. For better access to the crop region of a given view, regardless of the shape of the crop region, use the return from
GetCropRegionShapeManager.
Exceptions
RemarksThe X direction of the box is right on screen; Y is up; and Z is towards the user. The crop box Z value of a plan view is not meaningful.
See Also