UpdaterRegistryGetIsUpdaterOptional Method |
Check if the updater is optional or not.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool GetIsUpdaterOptional(
UpdaterId id
)
Public Shared Function GetIsUpdaterOptional (
id As UpdaterId
) As Boolean
public:
static bool GetIsUpdaterOptional(
UpdaterId^ id
)
static member GetIsUpdaterOptional :
id : UpdaterId -> bool
Parameters
- id UpdaterId
-
Id of the updater to check
Return Value
Boolean
Returns True if the updater is optional, False otherwise.
Exceptions
Remarks
This flag controls whether an updater is going to be required next time a document in which
it had been used is opened. If a non-optional updater is not found (currently not registered)
in a document, the end user will be presented with a warning and choices to resolve
the situation.
See Also