FieldBuilderSetDocumentation Method |
Sets the documentation string for the Field.
Namespace: Autodesk.Revit.DB.ExtensibleStorageAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FieldBuilder SetDocumentation(
string documentation
)
Public Function SetDocumentation (
documentation As String
) As FieldBuilder
public:
FieldBuilder^ SetDocumentation(
String^ documentation
)
member SetDocumentation :
documentation : string -> FieldBuilder
Parameters
- documentation String
-
The documentation string.
Return Value
FieldBuilder
The FieldBuilder object may be used to add more details to the field.
Exceptions
Remarks
While Entities may be hidden using access levels, Schemas and Fields are visible to
clients and other developers. In the interest of clarity and interoperability, you are
very strongly encouraged to provide good documentation with your Schemas.
Explain the intent of the data and how it is meant to be interpreted. It is not
useful to repeat information that can be observed directly (e.g. types and units).
Note that documentation, like all other contents of Schemas and Fields is immutable
once the add-in using the Schema is published.
See Also