DocumentIsBackgroundCalculationInProgress Method |
Indicates whether there are any background calculations in progress for this document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsBackgroundCalculationInProgress()
Public Function IsBackgroundCalculationInProgress As Boolean
public:
bool IsBackgroundCalculationInProgress()
member IsBackgroundCalculationInProgress : unit -> bool
Return Value
Boolean
Returns true if the document has any data calculation in progress and false otherwise.
Remarks
When a document has background calculations in progress, users cannot perform the following operations:
- Save/Close the document.
- Export/Print the document.
- Synchronize to central, in worksharing environment.
- Create a steel element.
- Copy/Mirror/Rotate a steel element.
- Edit the sketch of plate element.
- Edit a custom connection.
See Also