FamilyInstanceGetReferenceByName Method |
Gets the family instance reference corresponding to the named reference plane in the instance's family.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Reference GetReferenceByName(
string name
)
Public Function GetReferenceByName (
name As String
) As Reference
public:
Reference^ GetReferenceByName(
String^ name
)
member GetReferenceByName :
name : string -> Reference
Parameters
- name String
-
The name of the reference plane in the family.
Return Value
Reference
Returns the family instance reference corresponding to the named reference plane in the instance's family.
Returns null if there is no reference plane with this name in the family, or if the plane exists but its "Is Reference" property is "Not a Reference",
or if the input string is empty.
Exceptions
Remarks
If there is a reference plane in the instance's family that has the given name, and the plane's "Is Reference" property is not "Not a Reference",
there will be a corresponding reference in the family's instance. This function returns that reference.
See Also