ExternalServiceGetPublicAccessKey Method

Access key to use to execute a service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Guid GetPublicAccessKey()

Return Value

Guid
GUID representing the access key.
Exceptions
ExceptionCondition
InvalidOperationException The service is not public, thus the access key cannot be obtained.
Remarks

The service must be declared as public in order for callers be able to invoke this method. Services that are not public can be executed only by their owners (the ones who registered it).

Most services are not public and may only be executed by their respective owners. To see whether a service was declared as public, call the GetOptions method and check the IsPublic property.

See Also