MultiServerServiceGetActiveServerIds Method |
Returns Ids of the currently active application-level servers registered for the service.
Namespace: Autodesk.Revit.DB.ExternalServiceAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IList<Guid> GetActiveServerIds()
Public Function GetActiveServerIds As IList(Of Guid)
public:
IList<Guid>^ GetActiveServerIds()
member GetActiveServerIds : unit -> IList<Guid>
Return Value
IListGuid
A set of GUIDs of the application-wide active servers; the list may be empty.
Remarks
More than one application-level server can be active at a given time in a multi-server service,
but it is possible that no server is active (unless the service is mandatory).
See Also