ElectricalSettingRemoveWireMaterialType Method |
Remove the wire material type from project.
Namespace: Autodesk.Revit.DB.ElectricalAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void RemoveWireMaterialType(
WireMaterialType materialType
)
Public Sub RemoveWireMaterialType (
materialType As WireMaterialType
)
public:
void RemoveWireMaterialType(
WireMaterialType^ materialType
)
member RemoveWireMaterialType :
materialType : WireMaterialType -> unit
Parameters
- materialType WireMaterialType
- The wire material type to be removed.
ExceptionsException | Condition |
---|
InvalidOperationException |
Wire material type can be removed only if it is not currently assigned to any wire type,
and the last one wire material type can't be removed, otherwise an exception will be thrown.
|
See Also