TransformMultiply Operator |
Multiplies the two specified transforms.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Transform operator *(
Transform left,
Transform right
)
Public Shared Operator * (
left As Transform,
right As Transform
) As Transform
public:
static Transform^ operator *(
Transform^ left,
Transform^ right
)
static let inline (*)
left : Transform *
right : Transform : Transform
Parameters
- left Transform
- The first transformation.
- right Transform
- The second transformation.
Return Value
TransformThe transformation equal to the composition of the two transformations.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown when the handle of the first or second transformation is .
|
Remarks
The combined transformation has the same effect as applying the right transformation first,
and the left transformation, second. So, (T1(T2(p)) = (T1 * T2) (p).
See Also