AreaVolumeSettingsSetSpatialElementBoundaryLocation Method |
Sets the spatial element boundary location of a spatial element type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetSpatialElementBoundaryLocation(
SpatialElementBoundaryLocation spatialElementBoundaryLocation,
SpatialElementType spType
)
Public Sub SetSpatialElementBoundaryLocation (
spatialElementBoundaryLocation As SpatialElementBoundaryLocation,
spType As SpatialElementType
)
public:
void SetSpatialElementBoundaryLocation(
SpatialElementBoundaryLocation spatialElementBoundaryLocation,
SpatialElementType spType
)
member SetSpatialElementBoundaryLocation :
spatialElementBoundaryLocation : SpatialElementBoundaryLocation *
spType : SpatialElementType -> unit
Parameters
- spatialElementBoundaryLocation SpatialElementBoundaryLocation
-
The boundary location.
- spType SpatialElementType
-
The spatial element type.
ExceptionsException | Condition |
---|
ArgumentException |
Currently only SpatialElementType.Room is permitted when setting the boundary location.
|
ArgumentOutOfRangeException |
A value passed for an enumeration argument is not a member of that enumeration
|
See Also