FailureSeverity Enumeration |
Enum represents severity of a failure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum FailureSeverity
Public Enumeration FailureSeverity
public enum class FailureSeverity
MembersMember name | Value | Description |
---|
None | 0 |
Represents a failure-free state of a document. This value cannot be used as an argument to construct FailureMesasage.
|
Warning | 1 |
Failure that can be ignored by end-user. Failures of this severity do not prevent transactions from being committed.
|
Error | 2 |
Failure that cannot be ignored.
If FailureMeassage of this severity is posted, the current transaction cannot be committed unless
failure is resolved via appropriate FailureResolution.
|
DocumentCorruption | 3 |
Failure that forces Transaction to be rolled back as soon as possible due to known corruption to a document.
When failure of this severity is posted, reading of information from a document is not allowed.
The current transaction has to be rolled back first in order to work with the document.
|
See Also