ElementIntersectsSolidFilter(Solid, Boolean) Constructor |
Constructs a filter to match elements which intersect the given element, with the
option to match all elements not intersecting the given element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementIntersectsSolidFilter(
Solid solid,
bool inverted
)
Public Sub New (
solid As Solid,
inverted As Boolean
)
public:
ElementIntersectsSolidFilter(
Solid^ solid,
bool inverted
)
new :
solid : Solid *
inverted : bool -> ElementIntersectsSolidFilter
Parameters
- solid Solid
-
The solid geometry to check for intersection.
- inverted Boolean
-
True if the filter should match all elements which do not intersect the given
element.
Exceptions
See Also